GCC 4.4.7 and pkgsrc-current (April/May 2017)

# env CC=/data/gcc-new/bin/gcc CXX=/data/gcc-new/bin/g++ CFLAGS=-O2 ./bootstrap
CC libarchive/archive_check_magic.lo
 CC libarchive/archive_cmdline.lo
 CC libarchive/archive_cryptor.lo
 CC libarchive/archive_digest.lo
 CC libarchive/archive_entry.lo
 CC libarchive/archive_entry_copy_stat.lo
 CC libarchive/archive_entry_link_resolver.lo
 CC libarchive/archive_entry_sparse.lo
libarchive/archive_entry_sparse.c:53: error: conflicting types for 'archive_entry_sparse_add_entry'
libarchive/archive_entry.h:603: note: previous declaration of 'archive_entry_sparse_add_entry' was here
libarchive/archive_entry_sparse.c:137: error: conflicting types for 'archive_entry_sparse_next'
libarchive/archive_entry.h:613: note: previous declaration of 'archive_entry_sparse_next' was here
*** [libarchive/archive_entry_sparse.lo] Error code 1

bmake[1]: stopped in /pkgsrc/pkgsrc/bootstrap/work/libarchive
1 error

bmake[1]: stopped in /pkgsrc/pkgsrc/bootstrap/work/libarchive
*** [all] Error code 2

bmake: stopped in /pkgsrc/pkgsrc/bootstrap/work/libarchive
1 error

bmake: stopped in /pkgsrc/pkgsrc/bootstrap/work/libarchive
===> exited with status 2
aborted.

 

Advertisements
Gallery | This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s